// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[tT][0-9]+[_])(.*)(submit$)").unwrap();
let string = "
t1_click
t123_click_submit
T12_click_click_submit
t12_click_click_skip
t1234_click_click_click_skip
t12_clcik_sdsdssd
t1234_click_xyz
T12_click
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}