import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[tT][0-9]+[_])(.*)(submit$)";
final String string = "\n"
+ "t1_click\n"
+ "t123_click_submit\n"
+ "T12_click_click_submit\n"
+ "t12_click_click_skip\n"
+ "t1234_click_click_click_skip\n"
+ "t12_clcik_sdsdssd\n"
+ "t1234_click_xyz\n"
+ "T12_click\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}