const regex = /(^[tT][0-9]+[_])(.*)(submit$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[tT][0-9]+[_])(.*)(submit$)', 'gm')
const str = `
t1_click
t123_click_submit
T12_click_click_submit
t12_click_click_skip
t1234_click_click_click_skip
t12_clcik_sdsdssd
t1234_click_xyz
T12_click
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}