re = /(^[tT][0-9]+[_])(.*)(submit$)/m
str = '
t1_click
t123_click_submit
T12_click_click_submit
t12_click_click_skip
t1234_click_click_click_skip
t12_clcik_sdsdssd
t1234_click_xyz
T12_click
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end