#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[tT][0-9]+[_])(.*)(submit$)"
Local $sString = "" & @CRLF & _
"t1_click" & @CRLF & _
"t123_click_submit" & @CRLF & _
"T12_click_click_submit" & @CRLF & _
"t12_click_click_skip" & @CRLF & _
"t1234_click_click_click_skip" & @CRLF & _
"t12_clcik_sdsdssd" & @CRLF & _
"t1234_click_xyz" & @CRLF & _
"T12_click" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")