package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[tT][0-9]+[_])(.*)(submit$)`)
var str = `
t1_click
t123_click_submit
T12_click_click_submit
t12_click_click_skip
t1234_click_click_click_skip
t12_clcik_sdsdssd
t1234_click_xyz
T12_click
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}