// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) ([a-z ]*([A-Z])[a-z ]*)").unwrap();
let string = "$txt['addThe_fer_Te'] = 'Adds a Notification System to The rEst';
$txt['cs_add'] = 'Add';
$txt['add_stuff'] = 'Add stuff';
$txt['take_out'] = 'The Trash';";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}