import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " ([a-z ]*([A-Z])[a-z ]*)";
final String string = "$txt['addThe_fer_Te'] = 'Adds a Notification System to The rEst';\n"
+ "$txt['cs_add'] = 'Add';\n"
+ "$txt['add_stuff'] = 'Add stuff';\n"
+ "$txt['take_out'] = 'The Trash';";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}