$re = '/ ([a-z ]*([A-Z])[a-z ]*)/m';
$str = '$txt[\'addThe_fer_Te\'] = \'Adds a Notification System to The rEst\';
$txt[\'cs_add\'] = \'Add\';
$txt[\'add_stuff\'] = \'Add stuff\';
$txt[\'take_out\'] = \'The Trash\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);