package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) ([a-z ]*([A-Z])[a-z ]*)`)
var str = `$txt['addThe_fer_Te'] = 'Adds a Notification System to The rEst';
$txt['cs_add'] = 'Add';
$txt['add_stuff'] = 'Add stuff';
$txt['take_out'] = 'The Trash';`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}