re = / ([a-z ]*([A-Z])[a-z ]*)/m
str = '$txt[\'addThe_fer_Te\'] = \'Adds a Notification System to The rEst\';
$txt[\'cs_add\'] = \'Add\';
$txt[\'add_stuff\'] = \'Add stuff\';
$txt[\'take_out\'] = \'The Trash\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end