#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m) ([a-z ]*([A-Z])[a-z ]*)"
Local $sString = "$txt['addThe_fer_Te'] = 'Adds a Notification System to The rEst';" & @CRLF & _
"$txt['cs_add'] = 'Add';" & @CRLF & _
"$txt['add_stuff'] = 'Add stuff';" & @CRLF & _
"$txt['take_out'] = 'The Trash';"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")