re = /^[A-Z]+(-\d+)?/m
str = 'OIDC-2843 Resource URL by domain in OIDC conf.doc.
BAPP-1234 Lorem Ipsum Tra La La
NOJIRA Updated deploy docs standard (edited) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end