using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]+(-\d+)?";
string input = @"OIDC-2843 Resource URL by domain in OIDC conf.doc.
BAPP-1234 Lorem Ipsum Tra La La
NOJIRA Updated deploy docs standard (edited) ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}