#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]+(-\d+)?"
Local $sString = "OIDC-2843 Resource URL by domain in OIDC conf.doc." & @CRLF & _
"BAPP-1234 Lorem Ipsum Tra La La" & @CRLF & _
"NOJIRA Updated deploy docs standard (edited) "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")