import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]+(-\\d+)?";
final String string = "OIDC-2843 Resource URL by domain in OIDC conf.doc.\n"
+ "BAPP-1234 Lorem Ipsum Tra La La\n"
+ "NOJIRA Updated deploy docs standard (edited) ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}