$re = '/^[A-Z]+(-\d+)?/m';
$str = 'OIDC-2843 Resource URL by domain in OIDC conf.doc.
BAPP-1234 Lorem Ipsum Tra La La
NOJIRA Updated deploy docs standard (edited) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);