package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]+(-\d+)?`)
var str = `OIDC-2843 Resource URL by domain in OIDC conf.doc.
BAPP-1234 Lorem Ipsum Tra La La
NOJIRA Updated deploy docs standard (edited) `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}