// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\/videos\/(?:t\.\d+\/)?(\d+)").unwrap();
let string = "https://www.facebook.com/nikololok/videos/t.100000216422619/10153335471682286/?type=2
https://www.facebook.com/nikololok/videos/10153335471682286/
https://www.facebook.com/videos/10153335471682286/
https://www.facebook.com/krakstv/videos/vb.685118911556823/877578582310854/?type=2&theater";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}