#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\/videos\/(?:t\.\d+\/)?(\d+)"
Local $sString = "https://www.facebook.com/nikololok/videos/t.100000216422619/10153335471682286/?type=2" & @CRLF & _
"https://www.facebook.com/nikololok/videos/10153335471682286/" & @CRLF & _
"https://www.facebook.com/videos/10153335471682286/" & @CRLF & _
"https://www.facebook.com/krakstv/videos/vb.685118911556823/877578582310854/?type=2&theater"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")