$re = '/\/videos\/(?:t\.\d+\/)?(\d+)/i';
$str = 'https://www.facebook.com/nikololok/videos/t.100000216422619/10153335471682286/?type=2
https://www.facebook.com/nikololok/videos/10153335471682286/
https://www.facebook.com/videos/10153335471682286/
https://www.facebook.com/krakstv/videos/vb.685118911556823/877578582310854/?type=2&theater';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);