use strict;
my $str = 'https://www.facebook.com/nikololok/videos/t.100000216422619/10153335471682286/?type=2
https://www.facebook.com/nikololok/videos/10153335471682286/
https://www.facebook.com/videos/10153335471682286/
https://www.facebook.com/krakstv/videos/vb.685118911556823/877578582310854/?type=2&theater';
my $regex = qr/\/videos\/(?:t\.\d+\/)?(\d+)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}