const regex = /\/videos\/(?:t\.\d+\/)?(\d+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/videos\\\/(?:t\\.\\d+\\\/)?(\\d+)', 'gi')
const str = `https://www.facebook.com/nikololok/videos/t.100000216422619/10153335471682286/?type=2
https://www.facebook.com/nikololok/videos/10153335471682286/
https://www.facebook.com/videos/10153335471682286/
https://www.facebook.com/krakstv/videos/vb.685118911556823/877578582310854/?type=2&theater`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}