# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/videos\/(?:t\.\d+\/)?(\d+)"
test_str = ("https://www.facebook.com/nikololok/videos/t.100000216422619/10153335471682286/?type=2\n"
"https://www.facebook.com/nikololok/videos/10153335471682286/\n"
"https://www.facebook.com/videos/10153335471682286/\n"
"https://www.facebook.com/krakstv/videos/vb.685118911556823/877578582310854/?type=2&theater")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.