import Foundation
let pattern = #"^(\[(WIP|Draft)\]|(WIP|Draft))(:|\s)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[WIP]: lulz
[Draft]: hahaha
[Draft] lalalala
WIP: blah
WIP m000
Draft: foo
Draft: nope
WIP: more nope
WIP yeeeep
WIP:ahoy
WIP: ahoy matey!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)