$re = '/^(\[(WIP|Draft)\]|(WIP|Draft))(:|\s)?/m';
$str = '[WIP]: lulz
[Draft]: hahaha
[Draft] lalalala
WIP: blah
WIP m000
Draft: foo
Draft: nope
WIP: more nope
WIP yeeeep
WIP:ahoy
WIP: ahoy matey!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);