package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\[(WIP|Draft)\]|(WIP|Draft))(:|\s)?`)
var str = `[WIP]: lulz
[Draft]: hahaha
[Draft] lalalala
WIP: blah
WIP m000
Draft: foo
Draft: nope
WIP: more nope
WIP yeeeep
WIP:ahoy
WIP: ahoy matey!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}