import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\[(WIP|Draft)\\]|(WIP|Draft))(:|\\s)?";
final String string = "[WIP]: lulz\n"
+ "[Draft]: hahaha\n"
+ "[Draft] lalalala\n"
+ "WIP: blah\n"
+ "WIP m000\n"
+ "Draft: foo\n"
+ " Draft: nope\n"
+ " WIP: more nope\n"
+ "WIP yeeeep\n"
+ "WIP:ahoy\n"
+ "WIP: ahoy matey!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}