const regex = new RegExp('^(\\[(WIP|Draft)\\]|(WIP|Draft))(:|\\s)?', 'gm')
const str = `[WIP]: lulz
[Draft]: hahaha
[Draft] lalalala
WIP: blah
WIP m000
Draft: foo
Draft: nope
WIP: more nope
WIP yeeeep
WIP:ahoy
WIP: ahoy matey!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}