re = /^(\[(WIP|Draft)\]|(WIP|Draft))(:|\s)?/m
str = '[WIP]: lulz
[Draft]: hahaha
[Draft] lalalala
WIP: blah
WIP m000
Draft: foo
Draft: nope
WIP: more nope
WIP yeeeep
WIP:ahoy
WIP: ahoy matey!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end