use strict;
my $str = '1996
199610
19961005
1996100513
199610051322
19961005132200
19961005132200.124
19961005132200.124[-5]
19961005132200.124[-5:EST]
19961005132200.124[-5.30:EST]
19961005132200.124[-5.30:]
19961005132200.124[-5.30]
19961005132200.124[+5]
19961005132200.124[+5.30]
19961005132200.124[+5:EST]
19961005132200.124[+5.30:EST]
19961005132200.124[+5.30:]
19961005132200.124[5]
19961005132200.124[5.30]
19961005132200.124[5:EST]
19961005132200.124[5.30:EST]
19961005132200.124[5.30:]
';
my $regex = qr/^(?<year>\d{4})(?:(?<month>\d{2})(?:(?<day>\d{2})(?:(?<hour>\d{2})(?:(?<minute>\d{2})(?:(?<second>\d{2})(?:.(?<millis>\d{3})(?:\[(?:(?<offsetSign>[+-]?)(?<offsetHour>\d{1,2}))(?:.(?<offsetMin>\d{2}))?(?::(?<tz>.*)?)?\])?)?)?)?)?)?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}