package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<year>\d{4})(?:(?<month>\d{2})(?:(?<day>\d{2})(?:(?<hour>\d{2})(?:(?<minute>\d{2})(?:(?<second>\d{2})(?:.(?<millis>\d{3})(?:\[(?:(?<offsetSign>[+-]?)(?<offsetHour>\d{1,2}))(?:.(?<offsetMin>\d{2}))?(?::(?<tz>.*)?)?\])?)?)?)?)?)?)?$`)
var str = `1996
199610
19961005
1996100513
199610051322
19961005132200
19961005132200.124
19961005132200.124[-5]
19961005132200.124[-5:EST]
19961005132200.124[-5.30:EST]
19961005132200.124[-5.30:]
19961005132200.124[-5.30]
19961005132200.124[+5]
19961005132200.124[+5.30]
19961005132200.124[+5:EST]
19961005132200.124[+5.30:EST]
19961005132200.124[+5.30:]
19961005132200.124[5]
19961005132200.124[5.30]
19961005132200.124[5:EST]
19961005132200.124[5.30:EST]
19961005132200.124[5.30:]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}