import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<year>\\d{4})(?:(?<month>\\d{2})(?:(?<day>\\d{2})(?:(?<hour>\\d{2})(?:(?<minute>\\d{2})(?:(?<second>\\d{2})(?:.(?<millis>\\d{3})(?:\\[(?:(?<offsetSign>[+-]?)(?<offsetHour>\\d{1,2}))(?:.(?<offsetMin>\\d{2}))?(?::(?<tz>.*)?)?\\])?)?)?)?)?)?)?$";
final String string = "1996\n"
+ "199610\n"
+ "19961005\n"
+ "1996100513\n"
+ "199610051322\n"
+ "19961005132200\n"
+ "19961005132200.124\n"
+ "19961005132200.124[-5]\n"
+ "19961005132200.124[-5:EST]\n"
+ "19961005132200.124[-5.30:EST]\n"
+ "19961005132200.124[-5.30:]\n"
+ "19961005132200.124[-5.30]\n"
+ "19961005132200.124[+5]\n"
+ "19961005132200.124[+5.30]\n"
+ "19961005132200.124[+5:EST]\n"
+ "19961005132200.124[+5.30:EST]\n"
+ "19961005132200.124[+5.30:]\n"
+ "19961005132200.124[5]\n"
+ "19961005132200.124[5.30]\n"
+ "19961005132200.124[5:EST]\n"
+ "19961005132200.124[5.30:EST]\n"
+ "19961005132200.124[5.30:]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}