#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<year>\d{4})(?:(?<month>\d{2})(?:(?<day>\d{2})(?:(?<hour>\d{2})(?:(?<minute>\d{2})(?:(?<second>\d{2})(?:.(?<millis>\d{3})(?:\[(?:(?<offsetSign>[+-]?)(?<offsetHour>\d{1,2}))(?:.(?<offsetMin>\d{2}))?(?::(?<tz>.*)?)?\])?)?)?)?)?)?)?$"
Local $sString = "1996" & @CRLF & _
"199610" & @CRLF & _
"19961005" & @CRLF & _
"1996100513" & @CRLF & _
"199610051322" & @CRLF & _
"19961005132200" & @CRLF & _
"19961005132200.124" & @CRLF & _
"19961005132200.124[-5]" & @CRLF & _
"19961005132200.124[-5:EST]" & @CRLF & _
"19961005132200.124[-5.30:EST]" & @CRLF & _
"19961005132200.124[-5.30:]" & @CRLF & _
"19961005132200.124[-5.30]" & @CRLF & _
"19961005132200.124[+5]" & @CRLF & _
"19961005132200.124[+5.30]" & @CRLF & _
"19961005132200.124[+5:EST]" & @CRLF & _
"19961005132200.124[+5.30:EST]" & @CRLF & _
"19961005132200.124[+5.30:]" & @CRLF & _
"19961005132200.124[5]" & @CRLF & _
"19961005132200.124[5.30]" & @CRLF & _
"19961005132200.124[5:EST]" & @CRLF & _
"19961005132200.124[5.30:EST]" & @CRLF & _
"19961005132200.124[5.30:]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")