// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([ ]*)([a-zA-Z]\S*)[ ]+(([a-zA-Z])([^\r\n\t\f\v ;]*));.*").unwrap();
let string = " CostSheetNodeId nodeId;
ItemId itemId;
PmfBatchSize batchSize; // Modification on 02 Jul 2012 by dakaxx - CR4316";
let substitution = "\\1public \\2 parm\\U\\4\\E\\5(\\2 _\\3 = \\3)\\n\\1{\\n\\1 _\\3 = \\3;\\n\\1 return \\3;\\n\\1}\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}