$re = '/([ ]*)([a-zA-Z]\S*)[ ]+(([a-zA-Z])([^\r\n\t\f\v ;]*));.*/';
$str = ' CostSheetNodeId nodeId;
ItemId itemId;
PmfBatchSize batchSize; // Modification on 02 Jul 2012 by dakaxx - CR4316';
$subst = "\1public \2 parm\U\4\E\5(\2 _\3 = \3)\n\1{\n\1 _\3 = \3;\n\1 return \3;\n\1}\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;