#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([ ]*)([a-zA-Z]\S*)[ ]+(([a-zA-Z])([^\r\n\t\f\v ;]*));.*"
Local $sString = " CostSheetNodeId nodeId;" & @CRLF & _
" ItemId itemId;" & @CRLF & _
"" & @CRLF & _
" PmfBatchSize batchSize; // Modification on 02 Jul 2012 by dakaxx - CR4316"
Local $sSubst = "\1public \2 parm\U\4\E\5(\2 _\3 = \3)\n\1{\n\1 _\3 = \3;\n\1 return \3;\n\1}\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)