package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([ ]*)([a-zA-Z]\S*)[ ]+(([a-zA-Z])([^\r\n\t\f\v ;]*));.*`)
var str = ` CostSheetNodeId nodeId;
ItemId itemId;
PmfBatchSize batchSize; // Modification on 02 Jul 2012 by dakaxx - CR4316`
var substitution = "\1public \2 parm\U\4\E\5(\2 _\3 = \3)\n\1{\n\1 _\3 = \3;\n\1 return \3;\n\1}\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}