# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([ ]*)([a-zA-Z]\S*)[ ]+(([a-zA-Z])([^\r\n\t\f\v ;]*));.*/\1public \2 parm\U\4\E\5(\2 _\3 = \3)\n\1{\n\1 _\3 = \3;\n\1 return \3;\n\1}\n/g;t' <<< " CostSheetNodeId nodeId;
ItemId itemId;
PmfBatchSize batchSize; // Modification on 02 Jul 2012 by dakaxx - CR4316"