using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([ ]*)([a-zA-Z]\S*)[ ]+(([a-zA-Z])([^\r\n\t\f\v ;]*));.*";
string substitution = @"\1public \2 parm\U\4\E\5(\2 _\3 = \3)\n\1{\n\1 _\3 = \3;\n\1 return \3;\n\1}\n";
string input = @" CostSheetNodeId nodeId;
ItemId itemId;
PmfBatchSize batchSize; // Modification on 02 Jul 2012 by dakaxx - CR4316";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}