import Foundation
let pattern = #"(?<city>[A-Z]{1,2})([^\S\r\n]|-)*(?<letters2>[A-Z]){1,2}[^\S\r\n]*(?<numbers>[0-9]{1,4})[^\S\r\n]*(?<suffix>E)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AB CD 1334E
A-CD 1334E
RZ-SN440 E
RZ - F4 E
RZ - F4223
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)