re = /(?<city>[A-Z]{1,2})([^\S\r\n]|-)*(?<letters2>[A-Z]){1,2}[^\S\r\n]*(?<numbers>[0-9]{1,4})[^\S\r\n]*(?<suffix>E)?/m
str = ' AB CD 1334E
A-CD 1334E
RZ-SN440 E
RZ - F4 E
RZ - F4223'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end