using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<city>[A-Z]{1,2})([^\S\r\n]|-)*(?<letters2>[A-Z]){1,2}[^\S\r\n]*(?<numbers>[0-9]{1,4})[^\S\r\n]*(?<suffix>E)?";
string input = @" AB CD 1334E
A-CD 1334E
RZ-SN440 E
RZ - F4 E
RZ - F4223";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}