import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<city>[A-Z]{1,2})([^\\S\\r\\n]|-)*(?<letters2>[A-Z]){1,2}[^\\S\\r\\n]*(?<numbers>[0-9]{1,4})[^\\S\\r\\n]*(?<suffix>E)?";
final String string = " AB CD 1334E \n"
+ " A-CD 1334E\n"
+ "RZ-SN440 E \n"
+ " RZ - F4 E \n"
+ " RZ - F4223";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}