// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<city>[A-Z]{1,2})([^\S\r\n]|-)*(?<letters2>[A-Z]){1,2}[^\S\r\n]*(?<numbers>[0-9]{1,4})[^\S\r\n]*(?<suffix>E)?").unwrap();
let string = " AB CD 1334E
A-CD 1334E
RZ-SN440 E
RZ - F4 E
RZ - F4223";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}