use strict;
my $str = ' AB CD 1334E
A-CD 1334E
RZ-SN440 E
RZ - F4 E
RZ - F4223';
my $regex = qr/(?<city>[A-Z]{1,2})([^\S\r\n]|-)*(?<letters2>[A-Z]){1,2}[^\S\r\n]*(?<numbers>[0-9]{1,4})[^\S\r\n]*(?<suffix>E)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}