import Foundation
let pattern = #"\b((?:[0-9]{1,3}\.){3}[0-9]{1,3})\b([:/]|$)(([0-9]{1,4})|([\S\d].+))(.*)|$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://10.213.39.59/path/jklk/llkkk"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}