import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:[0-9]{1,3}\\.){3}[0-9]{1,3})\\b([:/]|$)(([0-9]{1,4})|([\\S\\d].+))(.*)|$";
final String string = "http://10.213.39.59/path/jklk/llkkk";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}