$re = '/\b((?:[0-9]{1,3}\.){3}[0-9]{1,3})\b([:/]|$)(([0-9]{1,4})|([\S\d].+))(.*)|$/';
$str = 'http://10.213.39.59/path/jklk/llkkk';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);