re = /\b((?:[0-9]{1,3}\.){3}[0-9]{1,3})\b([:\/]|$)(([0-9]{1,4})|([\S\d].+))(.*)|$/
str = 'http://10.213.39.59/path/jklk/llkkk'
# Print the match result
str.match(re) do |match|
puts match.to_s
end